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Major Enhancements  
o Race Day Scoring.  Race Day Scoring is the application that will ultimately replace Race 

Director.  In this RD release, a way of exporting an entire Race Director race fully enabled for a 

RDS import has been developed – found under the File menu.    

o RSU Integration.  Major changes have been made in Tailor -> Divisions to the RSU Event 

assignment process.  A nice way to handle team relay using the RSU team level group 

restrictions to determine male / female / coed.  Added a way of sequencing relay team members 

based on a question response at RSU.  Added the capability to let RD divisions completely share 

the same RSU Event and RSU Result set. 

o Leader Board.  A separate app for customizable leader board displays is possible now for 

standard, lap and cross country races.  The cross country leader board displays the team finish 

list and updates with every finisher. 

o Lap Results.  Major change allowing for different ways of scoring a lap race by total distance 

where participants can randomly chose between a long loop and short loop. 

o RM Timing.  Added RM Timing as a new supported Chip System. 

o Active Timing.  Added a direct connect integration with Active Timing – including the integration 

with the Announcer screens.  Changes to enable results created through the Active Timing File 

Exporter to import into RD. 

Reports  
o NICA Reports.  Added plate number to NICA multiple race reports. 

o Athlinks.   Activated the Athlinks integration on the Results Reports menu.  

o Team Reporting.  Added the ability to score teams simply by the number of finishers on each 

team. 

o Lap Results.  Incorporated "Long/Short" into the Laps Results summary report for the scenario 

where the lap race is scored on a long/short loop course. 

o Announcer Screens.  Added an option for how age is shown.  Age, age group and none are the 

choices given. 

o Results Kiosks.  Added the ability to show an additional logo at the bottom of the printed output 

from the results kiosk.  Added the ability to have a kiosk label where there's only a logo file on the 

bottom. Added the ability to show a second logo on the results kiosk printout in a lap race. 

Enhanced the Kiosk computer options to sense and report when the scoring computer found 

using the Network button doesn't have the same active race as the kiosk computer. 

o Overall Finish List.  Added an option to the overall finish list to show only those with a missed 

split.  Added the ability to produce a file for missed splits to be used in the Division crossover 

function. Improved the look of the Age Group placement. 

o Age Group Report.  Cosmetic change for races with 4 segments to allow more space for the bib 

number. 

o Participant Data Filtering.  Added a participant data filtering option for participant weight. 

o BAA Extracts.  Added the ability to send split times as a part of the BAA export for marathons. 

Added the ability to track different categories of wheelchair participants for BAA qualification. 

o GRU Enhancements.  Added "Team Place", "Team Score" and "Individual Score" as columns 

that can be selected in spreadsheet and GRU output for XC races. Added the capability of 

combining results across all divisions in an event when publishing GRU results. 
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o Award Winners Reporting.  Enhanced this report (found on the Chip Results screen) to include 

categories for male and female top finishers. 

o DQ Reporting.  Added a global replacement for DQ on results reports. 

o Time of Day.  Added TOD for splits as an optional column choice for 6+ segment races. 

o Chip Read Density.  Added a button to the chip results import screen to produce a report 

showing timing location density by minute. 

o Team Reporting.  Bug correction to team reporting to for complicated scoring in very large races. 

o Race Series Reports.  Added showing country as a choice on Series reports. Added the 

participant ID to the Excel output. 

o Cross Country Finish List.  Added a .lif file output choice to the XC Finish List. 

o Race Progress Report.  Added details in the "On Course" section showing last split completed, 

next split and estimated time at next split. 

o Finish Lynx Extracts.  Added .lif output to the Overall Finish List and the Overall Laps report. 

Results Processing  
o Results Processing Speed.  Major enhancements to speed up results publishing from the chip 

results screen.  5x improvements in very large races (10,000 plus participants). 

o Gun/Chip Scoring by Division. Added the ability to score a division by gun time in a race where 

the race setting to score by chip time. 

o Lap Results.  Enhanced the Lap Results import to use the last start read instead of the initial 

read encountered when you're using the setting that the first read is to be processed as a start 

read.  Added the ability for an excel import of bib numbers to produce the exact same lap results 

for all bibs imported. Added the ability to trigger the gun time from the Lap Results screen. 

Enhanced the Import to use bib / chip assignments for RFID imports. 

o Chip Results.  Added the ability to see chip result import counts by division. Enhanced the chip 

results import screen when scoring races where each division is a separate race to remember the 

time filter settings by division and timing location. Added a "Skip All" option when importing reads 

where there is not a bib/chip assignment. Enhanced the Chip Results import to consider only the 

chip code when the source of the data is RFID Outreach. 

o Auto Import.  Enhanced the chip results import to not prompt about RSU Event switches when 

you are in auto import mode. Added a screen message so that you know when auto import is 

working and when it's waiting between cycles. Changed the maximum setting for the delay 

between auto import cycles from 99 seconds to 999 seconds. 

o Lap Results.  Changed the lap results import totals to allow showing the total imported reads 

when there are more than 100,000 reads.  

o Override Processing.  Fine tuning on the rules covering occurrence checking for chip results 

imports where a Timing Location has multiple occurrences. 

o Check Mat Processing.  Enhanced the Check Mat report with a setting to allow selecting only 

the final occurrence for the reporting.  Added an option to ignore non finishers and added filtering 

to not show post finish reads. 

o Trident / IPICO FTP Connection.  Added a second backup selection for connecting directly to 

the IPICO or Trident Elite systems. 

o Skipped Segments Tracking.  Enhancements to the skipped segment processing to better deal 

with missed reads when there is a wave time involved. 
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o Direct Connect.  Implemented a better approach for IPICO / Trident where you have a common 

start / finish on the Direct Connect screen. 

o Trident.  Added a button for filtering incoming data by reader and antenna. 

o PC Timer.  Adjustment to PC Timer to save backup data to normal RD path instead of directly 

into WINRACE. 

o Raw Data Improvements.  Enhanced the raw data view for IPICO / Trident to show reader and 

antenna.  Also, allow filtering by these elements. Added the ability to ignore selected raw chip 

reads by selecting them in the Raw Data view and marking them for deletion. 

o Unknown Participants.  Changed Unknown Participant setup in the chip results import to look at 

the bib number on the master participant file for races configured for this. 

o Override Imports.  Updated the Chip Results Override Import to work with the newly formatted 

data from the Tomato Timer. 

o Chip Assignments.  Added a check when you exit the bib/chip assignment process to alert you 

about any use of the same chip code for more than one bib number. 

Live Results  
o RD Go Results. Improved RSU publishing for 6+ segment races where there is not yet a finisher. 

Enhancement to avoid an RSU warning in results publishing for divisions with no posted results. 

Adjusted how RD sends results to RSU for a DQ participant so that the placement shows DQ at 

RSU. Enhanced the RSU lap race publishing to order the list by distance for Long/Short loop 

races. Enhanced the RSU Results List Template to allow for a column for penalty. Enhanced the 

RSU and overall finish results to not show age group placements for Top Finisher Only division 

results. Updated the RSU results publishing to send split ranking. Changes for races where the 

Top Finishers are scored by gun time.  The chip time for top finishers will be sent as the gun time 

unless the setting for showing TF chip times is set on. Added the ability to suppress results from 

publishing at the Division level. 

o Race Roster.  Enhancement for 6+ segment races where ranking is done by segment. 

o Auto GRU.  Added team name as a selectable field for auto GRU from the chip results screen.  

Participant Entry  
o Participant Update Screen.  Added the ability to the email send screen to associate a bib 

number with manually entered email addresses. Improved the general lookup by name to also 

include relay team members. Added a prompt to the RSU button to allow updating the participant 

data in RD with participant data from RSU.  Added Force DNS and Force DNF settings when you 

edit participant data from the chip results list. Added the RSU Check-in Status indicator to the 

Update - Participants screen and as a choice when creating a participant data export. 

Enhancement to the USAT Number edit. 
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Import / Export  
o RSU Participant Imports.  Added a prompt about deleting participants first when you attempt a 

participant data import from RSU in a race where you have participants already in RD, but no 

results posted. Added checking when you do a import of participant data from another race where 

the participant data has RSU registration IDs.  A new choice is given to reset these.  Allow bib 

number transfers to come through in the RSU participant data import (not for relay teams yet).  

Added Yes/No questions into the RSU Division assignment by question responses.  

Enhancements to the RSU Reset Reg ID process to identify participants imported from sources 

other than RD. Enhancement to not remove participants who are on a non-relay team where the 

team classification is not set up in RD. Added an option for imports an RSU Add-on into a RD 

Optional Data Field. 

o  

o Active Imports.  Enhanced the participant import with the option to map the RD Division to the 

Active Price Type 

o RSU Participant Uploads.  Added additional checking to the RSU upload to sense when RSU 

team numbers are different from when the previous upload occurred. 

o Spreadsheet Imports.  Enhanced the participant data import from a spreadsheet to deal with the 

registration date containing a time stamp. 

o Cross Country.  Added a filter to the athletic.net export to exclude Ghost finishers. Fine tuning of 

XC HTML for MileSplit. 

o CT Live.  Changes in Race Director to stay current with CT Live integration changes. 

o Race Roster.  Enhancements to the participant import for pulling in T-Shirt sizes. Added USAT 

number. 

o XACT Upload.  Added choices for whether or not to send bib no and tag code in the Xact 

participant upload. 

o Finish Lynx Exports.  Enhanced to produce the team name instead of the participant name of 

the team captain. 

o Get Me Registered.  Enhancement to the GMR participant import to allow for more than 50 races 

in the list.   

Tailoring  
o Race Tailoring.  Increased the max size of optional data fields 9 and 10 from 30 to 60.  On the 

Results 1 tab, updated the ways of rounding times to allow rounding up to the next full second 

(USATF), rounding up to the next tenth of a second (TFRRS) or no rounding (default).  Improved 

the Properties screen for common start / finish Timing Location properties to have better 

explanations and edits. Enhanced the Common Start/Finish to allow multiple split/finish line 

occurrences. 

o Team Setup.  Added a prompt asking if the vacated team should be deleted when using the 

Transfer in Tailor -> Teams. Changed the settings in Team Classifications for mixed gender 

teams to allow up to 99 per gender. 

o Chip Systems.  Enhanced the new Timing Locations properties window to handle J Chip. 

o Cloning a Race.  Enhanced the clone process in File -> New to ask if you want the age 

calculation date copied from the race you are cloning to the new race when the race you are 

making a copy of has a age calc date that differs from the race date.  
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o Bib / Chip Assignments.  For Trident UHF, added the ability to auto create pairs of 

hexadecimal/decimal pairs by bib number. Implemented new chip system settings and a way of 

auto fill for the IPICO UHF system.  Enhanced the bib/chip assignment auto fill for trident to allow 

for decimal chip encoding. 

Labels / Email  
o Race Director Emails.  Update to sending emails related to team relay.  

Miscellaneous  
o Help -> Support.  Implemented a new method of sending support incident details through Help -> 

Support. 

o Race History. Enhanced the Start New Year process in File -> History to create a new Group 

Type at RSU for each RD team classification and to create new teams at RSU if teams are 

preserved in RD from the previous year.  


