
The Race Director 
Version 2012 Enhancements 

Major Enhancements 

o Unlimited Segments/Splits. Added "Six or More" as a choice when you define the number of race 
segments. The chip results import screen has been enhanced to accommodate the full set of splits that you 
define. The overall and age group HTML results reports have been enhanced to show the increased number 
of splits. The full set of splits will also be generated in GRU output from the overall results report. 

o Improved HTML - All Extended HTML has been converted to a new technique using style sheets where you 
have control of the settings for font, size and can be specified by you.  The HTML generated is 65% smaller 
than the HTML generated in previous Race Director versions. 

o Importing Chip Overrides - If you use PC Timer or the Time Machine as a backup to your chip scoring 
system - to capture times that may have been missed by the chip system - there is a very nice way to 
integrate these times into Race Director now. From the Chip Results Import screen, use the "Overrides" 
button. On that screen, you'll see a new option to "Import" overrides. You have the option of importing only 
missing chip result times or having all imported times become the official result. 

o Report Line Templates - it is now possible for you to define your own report line layout for both the Overall 
and Age Group results report. A new function has been added to the Results Reports menu that takes you to 
the screen where you design the template. Then, when running the reports, you can choose any template that 
you have created. 

o Age Group / Overall Results Reports - Added the ability to record and save all of the answers to the 
prompts you encounter when running these reports. On subsequent runs of the report, the report is generated 
immediately without any interruption for answering the prompts. 

o J-Chip.  Added J-Chip to the list of supported chip systems. The bib/chip assignment screen, standard chip 
results import screen and lap results import screen have all been expanded to allow for J-Chip results files. 

Reports 

o Added a "Scrolling HTML" option for both the Age Group and Overall Results reports. This is designed in a 
way that you can control the scrolling speed, font, width of the scroll area and height of the scroll area. This is 
a great way to project results at a race site. 

o Did Not Start - Still On Course - Added new capabilities around tracking participants that are entered in the 
race but did not start. There is now capabilities to flag these participants by importing the bib numbers from a 
spreadsheet or flagging them in a participant grid. Once those that did not start are flagged, you get a more 
accurate reporting of DNF (Did Not Finish) on any of the results reports. This is very handy for accurately 
reporting those believed to be still on the course. 

o Added the ability to specify two FTP destinations. When entries exist for both FTP destinations, HTML and 
GRU output is sent to both automatically.  

o Enhanced the Team Packet Pickup report to give a choice of substitutes for City on the report. Besides City, 
you are given a choice of Email Address or any Optional Data Field. 

o Enhanced the Results Kiosk to directly connect to RFID (Accuchip) readers to capture the bib number. 

o Modified the Results Kiosk screen to show partial results in multiple segment races. The screen will show a 
result for each segment completed. 

o Enhanced the Results Kiosk to indicate the last time reported for the division in the error message received 
when there is no posted finish result. 

o Enhanced the Age Graded Results report so that you can pick any combination of divisions. When you select 
multiple divisions, you are given the choice of combining the participants into one report or showing each 
division independently. 

o Added an option to the Announcer screen to not show "Not Set Up" messages for participants not registered 
in the race. Also added a "Limit Selection" button so that you can restrict the participants available to the 
Announcer screen based on whatever filtering requirements you specify. 

o Enhanced the splash message text on the announcer screen to include up to 100 characters of text for each 
participant. 

o Added a setting to the team relay registration report allowing an option for page breaks by relay team. 

o Redesigned the Chip Return Audit report to better deal with races where you have multiple chips for each 
participant. 

o Modified the USAT results data export to not create an export record for disqualified participants. 
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o Made modifications to some of the multiple segment age group and overall results reports to insure that the 
bib number is a column on all of the printed reports. 

o Overall Results Report - The compressed version of this report has been modified to show age group 
placement instead of city. 

o Added a new "page by page" HTML as an alternative to scrolling HTML. This is developed for both the 
Overall and Age Group reports. Running this report requires a separate PC for running the report and yet 
another PC for projecting it. Both PCs would be in addition to the scoring PC. 

 

o Created versions of the summary lap reports that do not have a page break by division. 

o Added new options to the Chip Start / Finish Time Check report. Previously the report had only a choice for 
showing all start / finish times or show when either one is missing. Three more options were added: 1) Start 
times only, 2) Finish Times only, 3) Start Time After Finish. 

o Added the ability to calculate net times in the age graded results by either adding or subtracting the time rule. 

o Added an option to the Alpha List printed report to show participant detail lines using alternate bars as a 
background. 

o Made Age optional on the detail team report (non cross country). 

o Added the ability to separate out the top finishers (open, masters, etc) on the Age Group version of the Series 
Report. 

o Added the option of generating the Age Group report with male age groupings ahead of the female age 
groupings. 

o Added a summary Excel output to the Series report. This will create a single row for each person on the 
series report, with all race detail as separate columns. 

o Added and option of showing city, email or telephone number on the Team Registration report. 

o Added the HTML and Spreadsheet report option to the Team Relay Age Group Report. 

o Enhanced the label creation process at the end of the Age Group Award Winners report to create either a 
mailing label or and award sticker. 

o Enhanced the Results Kiosk to work better in races where the segment definition varies from division to 
division. This also takes into account when there are "Skip on Results" settings. The Kiosk now will format the 
data headings to be in line with the division that the participant is entered in. 

o Added the ability to show any combination of chip time, gun time and chip to gun difference on the Kiosk 
screen. 

o Age groups with no finishers - there is a new setting on the Age Group results report that indicates you want 
to see the age group shown even if there are no finishers in that age group. 

o Added an Excel output for cross country.  This allows for you to track performance of everyone on a team 
across multiple races. 

Results Processing 

o Added the ability to save "nth read" settings by split on the chip results import screen. This setting is now 
done directly on the chip results import screen and you no longer need to answer the prompt about which 
occurrence when you process the import. 

o Added some additional checking to the start times import. The import will now ignore any start time imported 
that is greater than an already posted finish time. So, when there are multiple start reads the last one that is 
greater than the gun time but less than the first posted segment or finish time will be saved as the official start 
time. 

o Added the capability for RFID (Accuchip) times to be processed including the date - which allows for scoring a 
standard or lap race that crosses midnight. 

o On the Chip Results Import screen, changed to allow both a lower and upper range for the times imported. 
This, instead of having only the option of "Ignore Times Under" when importing finish times or "Ignore Times 
Over" when importing start times. 

o When importing lap times when previously imported times exist, you now have the option of pulling in new 
times that might have been missed in the initial import. 

o Modified all chip system Direct Connect screens to work for races where there is separate finish lines by 
division. When this is the case, you now must specify on the Direct Connect screen which division the results 
are being processed for. 
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o Direct Connect Enhancements. All Direct Connect modules have been modified so you can define splits in 
races with 6 or more splits. This includes ChronoTrack (incuding ChronoStore), IPICO, MyLaps and RFID 
(Accuchip) systems. 

o Results from the Announcer Screen. Added an option to allow the generation of a results file automatically 
based on a timing you specify. 

o IPICO Elite Reader Import - Changed the chip results import to work better when you connect directly to the 
IPICO Elite readers. Now, the primary and secondary IP addresses can be specified by the type of time you 
are importing. You do this setup once and each time you pull times, the import process goes directly to the 
readers you have specified for the type of time. 

o MyLaps Chip in a Bib. There is a new setting for MyLaps setup which indicates that the bib number is 
contained in the chip code. This is the standard format now for their chip in a bib solution. When this setting is 
taken, it is no longer necessary to define a bib/chip assignment file - it is assumed that the bib number is the 
last 5 positions of the chip code. 

 

o Added a trap to catch scenarios where a participants start time is after their finish time. This can happen in 
races with wave starts and can be caused either by an incorrect start read or finish read. 

o Added the ability to capture 2nd occurrence reads in MyLaps Direct Connect. Currently, this can only be 
activated for connections 1 and 2. 

o Added the capability on the PC Timer to save the results data in chip system format so that data captured can 
be imported with other chip results. 

o Shortened the height slightly of the PC Timer screen to make it more adaptable to Net-Book PCs. 

o Added the ability to scan in bib / chip assignments directly from the J-Chip tag checker. 

Participant Entry 

o Made improvements for when you are using multiple computers to enter participants while in data share 
mode. 

o Added the ability to print either landscape or portrait participant ID labels from the Participant Entry screen. 

o Added the gender check by first name (see Tailor -> Options -> Part Info 2) to the participant data import in 
Update -> Participants.     

Import / Export 

o Microsoft Excel - For both importing from and exporting to Excel, you have more choices for the version of 
Excel that is used. On the System tab in Tailor -> Options, you can choose between standard formats - Excel 
2007/2010, Excel 97 - 2003 and the version that Race Director has always used Excel 5.0 / 95. 

o Added a new setting on the email screen found in Labels / Export to give you a choice as to whether or not 
you want multiple emails to go to different participants with the same email address. 

o For races where there is a separate bib number range by division, modified the participant import to assign 
the next available bib number based on the division in the imported participant record. 

Tailoring 

o Early Start Divisions - Enhanced the start time import to allow for when you have an early start division where 
the wave time is added. The change will allow the gun time to be set as the time the full race begins and start 
times earlier than the gun time are allowed in. 

o Gave all of the chip system settings their own tab on the Tailor -> Options screen. 

o Elite Divisions - Added a setting in the Division tailoring where you can designate the division as qualifying for 
Top Finishers only. When you run a combined age group report, participants in this division will only show as 
top finishers and will not appear in the standard age groupings. This method of scoring is becoming more 
popular in triathlons. 

o For Elite divisions (where participants are are only eligible for top finisher awards), added an option where the 
Elites are only able to show in the top open age band. 

o New Top Finisher Category. Added a setting so that you can show the "Overall" finishers as a separate 
category ahead of all of the other age bands. The top Overall finishers represent the true top finishers of the 
race, by gender. 
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o Changed how you set the jumping rules in the Top Finishers setup so that you can have a different jumping 
rule set by division. 

o Added the ability to re-calibrate age group record-holders based on a specific starting year from the race 
history. This is useful for when there is a change to the length of the course in a given year. 

Labels / Email 

o Label Printer improvements. The Update -> Participants Label has been enhanced to work for label printers 
that print in either orientation - portrait (narrow label rolls) or landscape. The output is designed to fit on a 1 
inch by 3 inch label. The label generation found off the Reports menu has also been enhanced to include 
Label Types for label printers. 

o On participant ID label, when you select "Large Print Name", the bib number will print with the larger font as 
well. 

o Added an option to eliminate gender and age from the standard Participant ID label.  

o Enhanced the Email send procedure in Update -> Participants for Team Relay. Now, when you select 
participants to send registration confirmation or results emails, the relay members with valid email addresses 
will also be included. 

o Updated the "Default Results" email text to give a better example for multiple segment races - one that shows 
a results summary by segment. 

o Added a new setting on the email screen found in Labels / Export to give you a choice as to whether or not 
you want multiple emails to go to different participants with the same email address. 

Miscellaneous 

o The race list in File -> Open has been enhanced to also show the race date. This list has also been enhanced 
to allow showing it sequenced by race number, race name or race date. The sequencing can be either 
ascending or descending - making it easy to have the list sequenced by the most recent races at the top of 
the list. 

o Added more comprehensive software update checking. When it is sensed that the software needs an update, 
you are now prompted - asking if you would like the update downloaded automatically to your computer. 
Added a new entry under the File menu for downloading the latest software update at any time. Added a new 
entry under Start -> Programs -> Race Director to run the update. You must do a full software re-install to see 
this new entry. 

o Implemented a new program icon. Thank you Justin Mercer for doing the design work!! 

o Added a "Full System" option to both the File -> Backup and File -> Restore functions. This will make it much 
easier to copy all of your race data to another computer in a single Backup / Restore cycle. 

o Added a Data Select button to the bib assignment screen.  This allows a bib number re-assignment on only a 
subset of the entire race. 


